HOMEPlayers  Forum  Tables  Guide  
dark matter
ready! ready! ready! Adds 1 planetFinish actual research immediatelyFinish random build immediatelyForm 3 parts of random moonRepair most damaged ship by 10 levelsRandom factory building level upRandom logistic building level upRandom research level up (except colonization)Finish longest expedition immediatelyAdds 1 moon SPOILER ALERT 61.782.934.468*
Σ 45574 3653 ready! 9 88/100 [R] 10000/10000
You are browsing player:

Any suggestions, question, bug reports are very welcome.
user#3742019-12-22 03:22:05
Error when creating Moons

This shows up when I create Moons:

warning: mysql_result() [function.mysql-result]: Unable to jump to row 0 on MySQL result index 60 in /www/web_www/www/astro2/use_artefact_all.php on line 367

I have two planets and was trying to use moons to push them over the 140 minimum, and the Moons appear to be going on nothing, so I now have a bunch of Moons that don't seem to be attached to any planets.

I repeated this a second time, and I got the same error, so it wasn't a one-off either. When I got rid of those two planets and created 70 more, and then made more moons, this stopped happening, but I still have the moons attached to no planets.

Adam2020-01-14 09:59:35

Thank you for report an error, and sorry for late answer. I was trying to figure out why this error occurred with no success.

Do you still have these abandoned moons? I don't see them in your moons list.

user#3742020-01-14 23:07:41
Yep. When I destroy all my planets I'm left with the extra moons in my counter, yet they don't show up on any list anywhere.

Speaking of, I found a second unrelated bug.

By typing in a number to deliver resources to a Discovery, if you add a + on the end, you can deliver any amount you type in without it subtracting from your resources, even if you didn't have that many resources in the first place.

For example: if I have 100 crystals, I can type in 1000+ and it will both act as if I had delivered 1000 resources, but still leave me with the 100 crystals I already had.

Adam2020-01-15 11:53:04
There were 20 moons not attached to any planet, and all of them was yours!
The rest: 187999 moons in database are fine...
I deleted these 20 abandoned moons.
I don't know what happened, probably some database connection error while assigning moons to planets.

About the second bug - this is hilarious :))))
Have you discovered it accidentally by yourself or is it maybe well known php-form abuse?
I fixed it, now it allows only numbers and dots as a thousands separator.

Thanks again for reporting, especially the second bug... I'm still laughing :)

user#3742020-01-15 12:13:52
It might be a good idea to ensure every part of moon creation completes successfully so stray moons aren't left around. Otherwise, Idunno. It happened more than once, but then when I had more planets, it suddenly stopped happening, and I was in the process of sacrificing all my planets and getting new ones.

It might be. Seems like it would be the kind of thing that might mess with code if not checked for... there's some word for that that I'm not remembering.

It was an accident on my part though. I enter numbers with the numpad, and I must have accidentally slipped and put a + on the end. I noticed, but was already submitting it.

Adam2020-01-15 12:38:00
I think I found the moon problem.
While adding moons using artifacts you most probably did not have any valid planet(s) to place the moon at (maybe only asteroids).
I fixed it.

Page was generated in 0.129 seconds